Microsoft Security Advisory (2934088) Vulnerability in Internet Explorer Could Allow Remote Code Execution

Microsoft Security Advisory (2934088)
Vulnerability in Internet Explorer Could Allow Remote Code Execution

Microsoft has issued a security advisory for a zero-day exploit which was first identified in January and recently used in attacks against users of the US Veterans of Foreign Wars official site, as well as a decoy site for the French aerospace association GIFAS. While an actual patch has not been released, a 'fix it' implementation has been made available, as well as instructions that could be used to mitigate the vulnerability exploited by the zero-day. If possible, the easiest remedy would be to upgrade to the latest version of Internet Explorer, or choose to use alternative web browser software such as Mozilla Firefox, Google's Chrome, or Apple's Safari, all of which are full-featured cross platform browsers available to Windows users.